Game is running to fast.

Post here if you want help with Chao raising/breeding, or if you are a kind person that likes to help other people!
Post Reply
acetrainerkyle64
Newborn Chao
Newborn Chao
Posts: 6
Joined: Mon Dec 18, 2017 11:53 pm

Game is running to fast.

Post by acetrainerkyle64 » Tue Dec 19, 2017 12:10 am

My game is running at a really fast rate almost like it's on one of those emulators with 2x speed. I don't know how to slow it down.

User avatar
chaoadventures
Mystical Halloween Winner
Mystical Halloween Winner
Posts: 1326
Joined: Tue Dec 04, 2012 2:30 am
Motto: behold, it's a tailed frog! (very unique)
Location: http://ow.ly/LU9y30e51lb
Contact:

Re: Game is running to fast.

Post by chaoadventures » Tue Dec 19, 2017 3:26 am

...

- Which game? Sonic Adventure DX or Sonic Adventure 2? If it's SADX, then which version (2004 or Steam)?

- What's your operating system? (Windows 10, Windows 7, a Mac running through Wine, ect.)

- What's your graphics card? (Nvidia, AMD, Intel, ect. (can't do much for telling you how at the moment, but please also include GPU name and associated numbers))

- What's the refresh rate (Hz) of your monitor? (40 Hz, 60Hz, 120Hz, 144Hz, ect? (also can't help you much on getting that right now))

- Are you using any mods? (BetterSADX, Chao World Extended, anything using a ModLoader?)

- Have you gotten it to run at normal speed before?

I don't necessarily know the answer, but your post is really vague and makes it very hard for anyone with the answer to respond properly.
Image

- - -
Rajikaru wrote:You're clinically insane.

acetrainerkyle64
Newborn Chao
Newborn Chao
Posts: 6
Joined: Mon Dec 18, 2017 11:53 pm

Re: Game is running to fast.

Post by acetrainerkyle64 » Tue Dec 19, 2017 4:20 am

Sa2 steam I think
Windows 10
Nividia GeForce GT 650M
120Hz
I am using Chao world extended
I do use SA2 mod manager
and yes it used to run normal speed just fine.

User avatar
chaoadventures
Mystical Halloween Winner
Mystical Halloween Winner
Posts: 1326
Joined: Tue Dec 04, 2012 2:30 am
Motto: behold, it's a tailed frog! (very unique)
Location: http://ow.ly/LU9y30e51lb
Contact:

Re: Game is running to fast.

Post by chaoadventures » Tue Dec 19, 2017 4:43 am

Alright, the most concerning thing about the info you've given is your monitor's refresh rate.

To my knowledge, SA2 uses its frame rate to control everything it does (as it was originally coded with a Dreamcast displaying to a 60hz monitor in mind), so I'd imagine that that's the biggest problem.

If possible, try using Steam's frame rate checker to see if the game's window is displaying at 60 FPS or 120 (or some higher than 60 equivalent) FPS instead.
(if nothing's displaying at all try another frame checker)

If it is hovering above 60+, then open SA2's setup launcher (the one it always opens when opening the game through Steam itself), and see if the frame rate setting is set to 60Hz
(and if you can change it).

Image

If that's not possible to do, or it doesn't do anything, try a frame limiter (I've heard you can just use Nvidia's control panel for that). After that, the only ideas I have are to find and use a 60Hz monitor.

Of course, if the problem isn't monitor related I'm completely out of ideas as it stands.
Image

- - -
Rajikaru wrote:You're clinically insane.

acetrainerkyle64
Newborn Chao
Newborn Chao
Posts: 6
Joined: Mon Dec 18, 2017 11:53 pm

Re: Game is running to fast.

Post by acetrainerkyle64 » Tue Dec 19, 2017 4:58 am

I'm trying to figure out how to limit it through navidias control panel

acetrainerkyle64
Newborn Chao
Newborn Chao
Posts: 6
Joined: Mon Dec 18, 2017 11:53 pm

Re: Game is running to fast.

Post by acetrainerkyle64 » Tue Dec 19, 2017 5:08 am

Okay so I had to set my pc refresh rate to 60. It works but I want to find a way to just have it run the game like that and let me keep my pcs refresh rate at 120

User avatar
chaoadventures
Mystical Halloween Winner
Mystical Halloween Winner
Posts: 1326
Joined: Tue Dec 04, 2012 2:30 am
Motto: behold, it's a tailed frog! (very unique)
Location: http://ow.ly/LU9y30e51lb
Contact:

Re: Game is running to fast.

Post by chaoadventures » Tue Dec 19, 2017 5:36 am

Good that it's working.

From what I've found, instead of changing your whole monitor with Nvidia's control panel, you can use Nvidia Inspector to set a profile that alters that game only.

Assuming that you weren't already using that.
Image

- - -
Rajikaru wrote:You're clinically insane.

acetrainerkyle64
Newborn Chao
Newborn Chao
Posts: 6
Joined: Mon Dec 18, 2017 11:53 pm

Re: Game is running to fast.

Post by acetrainerkyle64 » Tue Dec 19, 2017 6:51 am

So I used the inhibator but now the game freezes after the first two title imgaes.

Post Reply